LogMeTT.com • TTSSH Comms error when disconnecting (random error)
Page 1 of 1

TTSSH Comms error when disconnecting (random error)

Posted: Wed Aug 02, 2017 1:24 am
by downpipe
Hi folks.
I am running the latest version 4.95 of Tera term.
I have struck an odd situation which I cannot code around.
I have a dos batch file that I use to run tera term and ttpmacro.
This batch file has run very well for years on both XP, windows 7.

My issue is the following.
When I disconnect from a device (Mostly Cisco devices), about 2 out of 10 times I get a popup window.

A communications error occurred while sending an SSH packet.
The connection will close. (retry_send_packet:10053)

A communications error occurred while sending an SSH packet.
The connection will close. (retry_send_packet:10053)

When I click on the ok button, the popup screen disappears.
I thought it could be my script.
So I clicked on the tera term icon, entered the ip address of the device
entered my username/password (using ssh) and connected fine.
When I typed in 'exit' or 'quit', I got the message.

When I do the exact same thing a minute later, no error.
It seems to be random, and I am struggling to find a work around.

Any help appreciated.

Cheers,
Joe

Re: TTSSH Comms error when disconnecting (random error)

Posted: Mon Aug 07, 2017 8:51 pm
by downpipe
After a little tinkering with my dos script I have managed to eliminate the error message.
The error still exists when I run tera term natively (ie as is from the icon on my desktop)

Here is what I did in my batch file.

A little background first.
The last line in the script contained the word 'exit'
This has worked for years, but for some reason I get the random error message

So, here is the solution

pause 1
disconnect 0
exit
exit

That fixed it.