• Support
  • Articles
  • Resources
  • Products
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead

Serial Port Connectivity

Moderator: boris

6 postsPage 1 of 1

boris
Moderator, LogMeTT and TTLEditor developer

Posts:
1598
Joined: Sat Jan 08, 2005 2:52 pm
by boris » Wed Mar 16, 2016 11:50 pm
Hi Yutaka and team,

I am observing the behavior that looks like a bug. Here is how to reproduce it:

I start Tera Term 4.90 and New Connection window pops up. I want to establish serial port connection, but I know the default baud rate in my TERATERM.INI file is 19200, while I need to establish connection at 9600 speed. So, I click Cancel button in New Connection window go to menu Setup->Serial port, change baud rate to 9600 and click OK. As soon as I click OK in Serial Port setup window, Tera Term opens serial port connection. When I then go back to New Connection window my COM port is not available anymore.

I hope this is not as per design, because user does not expect to open connection by changing port settings.
Thanks.
Best regards,
Boris
tumbleweed
Newbie

Posts:
3
Joined: Thu Mar 17, 2016 12:53 pm
by tumbleweed » Thu Mar 17, 2016 12:58 pm
I think it's always been this way, hasn't it? It's very handy for changing serial ports around, which I do frequently when working with embedded systems.

I'd hate to see it change where I always had to open a new connection.
Yutaka Hirata
TeraTerm Developer

Posts:
606
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Thu Mar 17, 2016 2:57 pm
Hi Boris,

Thank you for your feedback.
I check the latest source code of Tera Term and original code
of Tera Term Pro 2.3. As a result, it found that serial port
connectivity your reported is continued today through original
Tera Term Pro 2.3.

It seems that your problem is not bug but specification.

If you and some users request for improving this behavior,
we will consider a suggestion from yours.

Thanks.
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/
boris
Moderator, LogMeTT and TTLEditor developer

Posts:
1598
Joined: Sat Jan 08, 2005 2:52 pm
by boris » Thu Mar 17, 2016 4:32 pm

Attachments

VT serial port error.png
VT serial port error.png (14.9 KiB) Viewed 1237 times
Thanks.
Best regards,
Boris
tumbleweed
Newbie

Posts:
3
Joined: Thu Mar 17, 2016 12:53 pm
by tumbleweed » Thu Mar 17, 2016 5:12 pm
boris
Moderator, LogMeTT and TTLEditor developer

Posts:
1598
Joined: Sat Jan 08, 2005 2:52 pm
by boris » Thu Mar 17, 2016 6:29 pm
Thanks.
Best regards,
Boris
Display posts from previous:
Sort by:

6 postsPage 1 of 1

Users browsing this forum: No registered users