• Support
  • Articles
  • Resources
  • Products

Link Macro 1st error

Moderator: boris

2 postsPage 1 of 1

boris
Moderator, LogMeTT and TTLEditor developer

Posts:
1596
Joined: Sat Jan 08, 2005 2:52 pm
by boris » Thu Jun 25, 2015 10:31 pm
Hi,

I am running the following script

Code: Select all

  1. showtt -1
  2. timeout = 15 ; connection timeout in seconds
  3. connect "xx.xx.xx.xx:22 /ssh /2 /auth=password /user=boris /passwd=xxxxxxxxxx"
  4. testlink
  5. if result = 0 then
  6.   messagebox "Cannot link Tera Term with Macro. Click Ok to exit." "Connection Error"
  7.   showtt 1
  8.   end
  9. elseif result = 1 then
  10.   messagebox "Failed to connect to xx.xx.xx.xx on port 22. Click Ok to exit." "Connection Error"
  11.   showtt 1
  12.   end
  13. endif
  14. setsync 1
  15. showtt 1
  16. wait '$'
  17. sendln 'sudo su -'
  18. wait 'assword'
  19.  

When the server is not reachable and connection fails message box pops up informing that connection failed (line 10) but then showtt 1 command in the next line is causing "Link Macro 1st error".

Is this a bug? What showtt command has common with Tera Term's connected or not connected state?

I run few tests and discovered that this error only appears when connect command was executed and failed. Without attempt to connect the script shows/hides Tera Term window with showtt without any issue.
Thanks.
Best regards,
Boris
boris
Moderator, LogMeTT and TTLEditor developer

Posts:
1596
Joined: Sat Jan 08, 2005 2:52 pm
by boris » Fri Jun 26, 2015 4:58 pm
Here is the screenshot.
macro_error.png
macro_error.png (36.19 KiB) Viewed 645 times
Thanks.
Best regards,
Boris
Display posts from previous:
Sort by:

2 postsPage 1 of 1

Users browsing this forum: No registered users
cron