• Support
  • Articles
  • Resources
  • Products

Application Fault

Moderator: boris

9 postsPage 1 of 1

megajohn
Newbie

Posts:
7
Joined: Fri Mar 27, 2015 3:12 pm
by megajohn » Fri Mar 27, 2015 3:17 pm
Hi!

sorry my english.

I use 4.86

Com port open with flow control.

If i send file from attach ( please unpack ) then receive message box with content:

eax=004D28CC
ebx=00000001
ecx=3FFDAE33
edx=00000000
esi=00567000
edi=00564E0C
ebp=0012FE6C
esp=0012FE64
eip=0035923A
efl=00010202
_ _ cs=001B ss=0023 ds=0023 es=0023 fs=003B gs=0000
Exception: ACCESS_VIOLATION
#1 0x0035923a in --- at ttpcmn.dll
#2 0x00353e5d in CommRawOut() + 0x4d at ttpcmn.dll
#3 0x00156be8 in --- at <Unknown Module>

Attachments

tst100000.rar
(573 Bytes) Downloaded 113 times
Yutaka Hirata
TeraTerm Developer

Posts:
598
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Sat Mar 28, 2015 3:01 pm
Hi megajohn,

Thank you for your feedback.
Would you please use below archive and report the detail information
because I want to investigate your problem.

http://ttssh2.sourceforge.jp/snapshot/s ... _debug.zip
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/
megajohn
Newbie

Posts:
7
Joined: Fri Mar 27, 2015 3:12 pm
by megajohn » Mon Mar 30, 2015 1:20 pm
Yutaka Hirata wrote:Would you please use below archive and report the detail information


On my WinXP 32bit this soft not started ( MessageBox "Is not Win32 application" )
On second computer with Win7 64bit, started successfully, and work normal - no Application Fault ( but not showed transfer bytes )
tt_dbg_win7-64.gif
tt_dbg_win7-64.gif (11.82 KiB) Viewed 1897 times


I compare folder before and after, and do not find report file ( detect changes only in *.ini )

 

megajohn
Newbie

Posts:
7
Joined: Fri Mar 27, 2015 3:12 pm
by megajohn » Tue Mar 31, 2015 9:02 am
my experiments:

com port open with flow control

i manually locked CTS on my UART2USB driver.

TeraTetm send file, but transfer 100 bytes every 0,5 sec ( why ? CTS must block transfer )
teraterm_tx_if_cts_block.gif
teraterm_tx_if_cts_block.gif (9.93 KiB) Viewed 1873 times



if i release CTS, then get message box in start topic
Yutaka Hirata
TeraTerm Developer

Posts:
598
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Tue Mar 31, 2015 12:59 pm
Hi megajohn,

On my WinXP 32bit this soft not started ( MessageBox "Is not Win32 application" )


I have uploaded below archive supporting the Windows XP.
Please test your problem.

http://ttssh2.sourceforge.jp/snapshot/s ... vs2005.zip
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/
megajohn
Newbie

Posts:
7
Joined: Fri Mar 27, 2015 3:12 pm
by megajohn » Tue Mar 31, 2015 1:15 pm
Yutaka Hirata wrote:I have uploaded below archive supporting the Windows XP.


ttdbg_app_fault_cut.gif
ttdbg_app_fault_cut.gif (6.67 KiB) Viewed 1859 times


P.S. The image must be ... at most 740 pixels wide and 1024 pixels high. May be wide extend to more ? Example 1024
megajohn
Newbie

Posts:
7
Joined: Fri Mar 27, 2015 3:12 pm
by megajohn » Mon May 18, 2015 3:58 pm
Please, remember about me !
megajohn
Newbie

Posts:
7
Joined: Fri Mar 27, 2015 3:12 pm
by megajohn » Fri Jul 31, 2015 11:42 am
Tera Term project is going to release new version(4.87) on May 31, 2015.
So, we built the 4.87 RC1 version in the following:

Again FAULT !!!!
teraterm486b5883_fault.gif
teraterm486b5883_fault.gif (12.91 KiB) Viewed 1317 times
megajohn
Newbie

Posts:
7
Joined: Fri Mar 27, 2015 3:12 pm
by megajohn » Fri Jul 31, 2015 12:05 pm
4.87 fault

P.S. File open as binary

Attachments

teraterm487b5897_fault.gif
teraterm487b5897_fault.gif (12.95 KiB) Viewed 1314 times
Display posts from previous:
Sort by:

9 postsPage 1 of 1

Users browsing this forum: No registered users
cron