• Support
  • Articles
  • Resources
  • Products

SendMulticast Won't Send an Integer value of 0x00 or 0x01, but Send Will

Moderator: boris

1 postPage 1 of 1


Joined: Mon Mar 06, 2017 4:36 am
by jcorra » Mon Mar 06, 2017 5:14 am
I have observed an interesting behavior that I was not expecting. If I send out the integers from 0x00 to 0xFF using the Send command, they go out just fine, but if I try to send them out with the SendMulticast command 0x00 and 0x01 don't work. The 0x00 just doesn't seem to get sent and the 0x00 gets sent as 0xFF! I already switched the language to English from UTF-8 so that the upper values from 0x80 to 0xFF would send properly as a single byte.

My test setup is as follows:
1. Terminal 1 (named Terminal1) is connected to COM1
2. Terminal 2 (named Terminal2) is connected to COM2
3. I am running a RealTerm Terminal on COM3 (set to display received data as hex)
4. COM2 and COM3 are physically connected with a null-modem cable

If I run the following macro on Terminal 2, I get the numbers from 0x00 to 0xFF on the RealTerm Terminal on COM3 as expected:
for i 0x00 0xFF
send i

If I run the equivalent macro on Terminal 1, I get 0xFF and the numbers from 0x02 to 0xFF on the RealTerm Terminal on COM3, NOT as expected:
for i 0x00 0xFF
SendMulticast "Terminal1" i

What is going on here? Why can I send an integer value of 0x00 or 0x01 with the Send command, but not with the SendMulticast command? I would greatly appreciate any help in sorting this out. This is causing no small problem in my macro since all of the bytes with a value of 0x00 are getting skipped and the ones with a value of 0x01 are getting converted to 0xFF.

1 postPage 1 of 1

Users browsing this forum: No registered users