• Support
  • Articles
  • Resources
  • Products

print with WINDOWS 7 net use LPT PERSISTENT:Yes

Moderator: boris

4 postsPage 1 of 1

canepippo
Newbie

Posts:
1
Joined: Tue May 11, 2010 7:45 am
by canepippo » Tue May 11, 2010 8:01 am
i need to print with teraterm with a pinter usb in windows xp no problem i make the script

@echo off
net use LPT2 /delete
net use LPT2 \\ip or name pc\share name print \PERSISTENT:Yes

and in the teraterm.ini i set passthrueport: LPT2

in windows 7 this metod dont work but if i make net use in cmd LPT2 is OK and if i make dir > LPT2 the printer work.

i think the problem is Teraterm .. its possibile to resolve??

sorry for my bad english
David LECLERCQ
Newbie

Posts:
1
Joined: Tue Jul 13, 2010 2:52 pm
by David LECLERCQ » Thu Jul 15, 2010 7:26 am
I had same issues in teraterm 2.3. Dont know if it's the same with newer versions.
It s a problem with win7 rights usage to LPT ports.
You 'll need to modify the teraterm sources and compile it.

In COMMLIB.C
In then function : BOOL PrnOpen(PCHAR DevName)

CHANGE:
PrnID = CreateFile(Temp,GENERIC_WRITE,0,NULL,OPEN_EXISTING,0,NULL);
TO:
PrnID = CreateFile(Temp,GENERIC_WRITE | FILE_READ_ATTRIBUTES,FILE_SHARE_READ,0,CREATE_ALWAYS,0,0);

Best regards
Taklu
Newbie

Posts:
1
Joined: Fri Oct 21, 2011 8:20 am
by Taklu » Fri Oct 21, 2011 8:24 am
I would honestly consider setting up a server on a network like that, not just for printing, but for overall simplification. I've always avoided sharing out personal printers on client systems like the plague.
brudestroyer
Newbie

Posts:
1
Joined: Fri Mar 02, 2012 2:36 pm
by brudestroyer » Fri Mar 02, 2012 2:50 pm
@David LECLERCQ
Could you provide this compiled version? I'm still getting errors with newest version...
Display posts from previous:
Sort by:

4 postsPage 1 of 1

Users browsing this forum: No registered users
cron