• Support
  • Articles
  • Resources
  • Products
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead

Nortel Alteon 2208

Moderator: boris

25 postsPage 1 of 1

trankilou
by trankilou » Thu Mar 31, 2005 12:40 pm
Hi everybody,

I have the problem of ssh (v1) connection between teraterm and a Nortel Alteon application switch 2208 (Os 21.0.4)

The Alteon is a kind of switch which allow you to make hardware load-balancing...

Ok it's ssh server it's quiet special: here what i find in the doc

The Alteon Os implementation of SSH is based on version 1.5 and supports ssh clients version 1.5---1.x.xx only. The following ssh clients have been tested:
- SSH 1.2.23 ans SSH 1.2.27 for Linux (i tested too, it's works)
- SecureCRT 3.0.2
- F-Secure SSH 1.1



With Ethereal, i did compare the difference between a client which work and another which don't.

I noticed that the working client don't send their version.

Teraterm sent "SSH-1.5-TTSSH/2.11 Win32"

Is there a way to prevent this ?

Thanks

 

Yutaka Hirata
TeraTerm Developer

Posts:
606
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Sat Apr 02, 2005 5:23 am
Hi,

I caught a cold this week. I am not file well yet. But the heat of the cold fell.

By the way, I think that I can't modify TeraTerm not sending client ID because the client ID is used by generating SSH Diffie-Hellman exchange key. If so, TeraTerm could not establish the server with SSH proctol.
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/
trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Sun Apr 03, 2005 10:19 am
Hi Yutaka,

I hope you feal better .

:oops:

I think I understand what you tell me. But I ask myself, how make for example openssh to generate the SSH DH key without sending their ID ?

By the way , is it possible to send a false cleint ID ? (example SSH-1.2 instead of SSH-1.5-TTSSH/2.11 Win32)

Last question, is it possbile to get the source of the Last TTSSH 2.1 ? :roll:

Thanks for your answer and I hope you will feal better as soon as possible!

 

Yutaka Hirata
TeraTerm Developer

Posts:
606
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Sun Apr 03, 2005 10:52 am
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/
trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Mon Apr 04, 2005 8:26 am
trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Mon Apr 04, 2005 8:41 am
trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Mon Apr 04, 2005 12:55 pm

 

Yutaka Hirata
TeraTerm Developer

Posts:
606
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Mon Apr 04, 2005 12:57 pm
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/
trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Mon Apr 04, 2005 1:43 pm
Yutaka Hirata
TeraTerm Developer

Posts:
606
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Tue Apr 05, 2005 12:42 pm
Hi,

[quote="trankkilou"]
I have problems to compile cause of the language:cry: . Example , in ssh.c:

push_memdump("pure server ID", "ƒvƒ
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/
trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Tue Apr 05, 2005 2:35 pm
Hi yutaka,

Thanks you for your procedure ans your advice but the problem come from the japanase language. Thre are several well known KB (Microsoft problem) and the only way to bypass them is to remove the include ... :roll:

SYMPTOMS
In Visual C++ .NET, the Microsoft Foundation Class (MFC) Class Wizard creates header and implementation code for your class, and adds .cpp and .h files to the project. However, when you use the MFC Class Wizard to create a class in an MFC Extension DLL project, you may receive the following error message while compiling the project:
fatal error C1083: Cannot open include file: '<project name>.h': No such file or directory
CAUSE
The MFC Class Wizard incorrectly inserts code in the <classname>.cpp file to include the <project name>.h file.
WORKAROUND
To work around the problem, remove following line of code from the <classname>.cpp file:
#include "<project name>.h"
STATUS
Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.


In fact the build process block at the build of openssh :cry:

I'm afraid it will never work for europeans like us or maybe I made a mistake... :roll:
trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Wed Apr 06, 2005 10:03 am
Hi again,

I ask a question to ask you Yutaka.

Will it take a long time to remove all japanese from the source code so everybody on earth wich don't have windows/.Net in japanese, can continue the projet ? :roll:

 

Yutaka Hirata
TeraTerm Developer

Posts:
606
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Wed Apr 06, 2005 12:35 pm
Hi,

I will change the string of source code from Japanese to English in the future. Now I have no time to do it.
Currently TeraTerm developer is only me. Now no problem :?
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/
trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Wed Apr 06, 2005 3:55 pm
ok no problem it was just a question :D

So as you are the only developper , will you please compile one last time the ttxssh.ddl with this param in the ssh.c ? :D
_snprintf(TTSSH_ID, sizeof(TTSSH_ID),
"SSH-1.5-1.2.27\n");

Thanks thousand times

8)

Make sure I make a lot of pub around your project in france. As I work in a very famous and big compagny, be sure you gonna be famous too in france :wink:

 

Yutaka Hirata
TeraTerm Developer

Posts:
606
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Thu Apr 07, 2005 11:59 am
Hi,

I uploaded archive for you below:
http://sleep.mat-yan.jp/~yutaka/windows ... france.zip
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/
trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Thu Apr 07, 2005 2:32 pm
Hi yutaka,

I tested the last version and I glad to notice it works with teraterm :lol:


but not with ttpmacro with "connect /ssh /1 method" :cry:

With I try with the connect method I have this message:
from teraterm:
Detected corrupted data; connection terminating

From the ssh server:
SSH kEx Exchange failed (host 172.xx.xx.xx)

here the log of TTTSSH.log
When it works I have this:
---------------------------------------------------------------------
Initiating SSH session at Thu Apr 07 16:31:15 2005
Received server prologue string: SSH-1.5-1.2.27
Server reports supported authentication method mask = 8
Entering secure mode
Secure mode successfully achieved
Sending user name: admin
Server requires authentication
Trying PASSWORD authentication...
Authentication accepted
Terminating SSH session...



When it dosen't work I get this:
-[i]--------------------------------------------------------------------
Initiating SSH session at Thu Apr 07 16:29:41 2005
Received server prologue string: SSH-1.5-1.2.27
Server reports supported authentication method mask = 8
Entering secure mode
Detected corrupted data; connection terminating.
Terminating SSH session...[/i]




Do you have an idea ? :roll:

 

Yutaka Hirata
TeraTerm Developer

Posts:
606
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Fri Apr 08, 2005 12:49 pm
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/
trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Fri Apr 08, 2005 3:16 pm
ok,

Here the script (just the begining) witch work with Telnet:


;######### Variables ? modifier en cas de besoin #############

UserName = 'admin'
Password='toto'
AlteonType='Alteon_ApplicationSwitch_2208'


;######## !!! NE RIEN MODIFIER APRES CETTE LIGNE !!! ####################




;######## affectation de valeurs ? quelques variables utiles pour la suite #####
gettime Time
getdate Date
Getconf = '/cfg/dump'
ServerAddress = 192.168.1.1


;########### Connection au serveur ##############

msg = ServerAddress
strconcat msg ":23"
strconcat msg " /nossh /H /I"


connect msg
if result = 1 goto ConnectionFailure
if result = 0 goto ConnectionFailure


Pause 2
PasswordPrompt = 'Enter password:'
wait PasswordPrompt
sendln Password






Now The script wich should work but wich don't


;######### Variables ? modifier en cas de besoin #############

UserName = 'admin'
Password='toto'
AlteonType='Alteon_ApplicationSwitch_2208'


;######## !!! NE RIEN MODIFIER APRES CETTE LIGNE !!! ####################




;######## affectation de valeurs ? quelques variables utiles pour la suite #####
gettime Time
getdate Date
Getconf = '/cfg/dump'
ServerAddress = 192.168.1.1


;########### Connection au serveur ##############

msg = ServerAddress
strconcat msg ':22 /H /I /ssh /1 /auth=password /user='
strconcat msg username
strconcat msg ' /passwd='
strconcat msg Password


connect msg

if result = 1 goto ConnectionFailure
if result = 0 goto ConnectionFailure






Note this scipt work perfectly with other equipement
:roll:

 

Yutaka Hirata
TeraTerm Developer

Posts:
606
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Sun Apr 10, 2005 5:36 am
Hello,

I think that it is difficult to solve your problem.
Now I have no idea. I am sorry. :(

By the way, would you want the workaround "SSH-1.5-1.2.27" in TeraTerm?
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/

 

Ok
by Ok » Mon Apr 11, 2005 8:07 am
ok, no problem :lol:

What workaround mean ? :roll:

ok

trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Tue Apr 12, 2005 8:13 am
Hi yutaka,

I don't understand what your sentence mean ?

What do you hear by "would you want the workaround "SSH-1.5-1.2.27" in TeraTerm" ? :roll:

 

Yutaka Hirata
TeraTerm Developer

Posts:
606
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Tue Apr 12, 2005 2:19 pm
Hi,

I am sorry for my bad English.
Is it good to change optionally TTSSH version to "SSH-1.5-1.2.27" in TeraTerm?
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/

ok

trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Tue Apr 12, 2005 2:47 pm

 

Yutaka Hirata
TeraTerm Developer

Posts:
606
Joined: Wed Jan 12, 2005 2:35 pm
by Yutaka Hirata » Tue Apr 12, 2005 3:06 pm
Best regards, Yutaka Hirata
(yutakakn at gmail.com)
http://hp.vector.co.jp/authors/VA013320/
trankkilou
Newbie

Posts:
13
Joined: Thu Mar 24, 2005 11:32 am
by trankkilou » Tue Apr 12, 2005 3:55 pm
Display posts from previous:
Sort by:

25 postsPage 1 of 1

Users browsing this forum: No registered users
cron