• Support
  • Articles
  • Resources
  • Products

MACRO:Error (Link macro first. Use 'connect' macro

Moderator: boris

3 postsPage 1 of 1

EvoVI66
Newbie

Posts:
2
Joined: Fri Jan 13, 2017 11:05 am
by EvoVI66 » Fri Jan 13, 2017 11:16 am
Hey there.

We use teraterm to clear unit for re-sale. To speed up the process we obviously use macros but recently i have had an issue appear. When running macros directly from control>macro i receive the Link macro first error. These used to work perfectly fine but now no matter which ones i run this error persists. I can however make a macro starting with connect '/C=4' add in something like message box "hello" test" and it will work fine. Once i however issue a command that talks to the box say like wait or sendln i get this error if i then stop or continue the macro it appears the connection drops from serial completely.

For clarification i am just running to the box with cisco serial cable on COM 4 these macros used to work but now i get this error message. I tried adding connect '/C=4' to the start of the macro in an attempt to make sure there was a link but right after it connects and issues the first command this error pops up again.

P.S Excuse the bad use of my TTL language skills i am still pretty new to all this :)

Attachments

V240 In Progress.ttl
(2.01 KiB) Downloaded 20 times
Error.jpg
Error.jpg (22.16 KiB) Viewed 262 times
Trevor
Guru

Posts:
474
Joined: Wed Jul 26, 2006 8:47 am
by Trevor » Sat Jan 14, 2017 1:43 pm
Can you stick this at the beginning of your macro? It will confirm if the serial port is being opened or not.

Code: Select all

  1. testlink
  2. if result != 2 then
  3.     connect "/c=4"
  4.     testlink
  5.     if result != 2 then
  6.         messagebox "Unable to open COM4" "Error"
  7.         exit
  8.     endif
  9. endif
EvoVI66
Newbie

Posts:
2
Joined: Fri Jan 13, 2017 11:05 am
by EvoVI66 » Mon Jan 16, 2017 8:12 am
Hello

I have added the lines to my existing macro. I i indeed get the message "unable to open COM 4". If i however just open teraterm without the macro i am able to communicate with the unit just fine and issue commands using COM 4.

its almost like using a macro causes teraterm to close connections. As if i run the macro with COM 4 already open with just the wait command teraterm will post one more line from the unit then stop and i have to re-open the connection again.

Thanks
Display posts from previous:
Sort by:

3 postsPage 1 of 1

Users browsing this forum: No registered users
cron